logo
Loading...

無法安裝grab套件 出現了ERROR: Cannot uninstall 'pycurl'.的錯誤訊息 - Cupoy

我在使用pip install grab安裝套件時,發生了以下的錯誤。請問該如何解決呢? ERROR...

無法安裝grab套件 出現了ERROR: Cannot uninstall 'pycurl'.的錯誤訊息

2021/08/18 下午 10:07
Chu Chen
觀看數:6
回答數:1
收藏數:0

我在使用pip install grab安裝套件時,發生了以下的錯誤。請問該如何解決呢? ERROR: Cannot uninstall 'pycurl'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall. Note: you may need to restart the kernel to use updated packages.

回答列表

  • 2021/09/08 上午 10:53
    張維元 (WeiYuan)
    贊同數:0
    不贊同數:0
    留言數:0

    嗨,你好
    grab 有規定 pycurl 版本(可能跟預設 Python 安裝的版本不符合),因此需要把現有的 pycurl 移除後安裝對應的版本。參考文件: https://github.com/lorien/grab/issues/374

    嗨,你好,我是維元,持續在不同的平台發表對 #資料科學、 #網頁開發 或 #軟體職涯 相關的文章。如果對於內文有疑問都歡迎與我們進一步的交流,都可以追蹤 我的粉絲專頁 ヽ(●´∀`●)ノ