logo
Loading...

Anaconda 4.7.12 (最新版) openCV 裝不起來 - Cupoy

我在今年2月裝的Anaconda可能因為Windows update壞了, 所以我把所有的pytho...

cvdl-1,cvdl-1-d09

Anaconda 4.7.12 (最新版) openCV 裝不起來

2019/12/08 01:24 AM
電腦視覺深度學習論壇
林弘敏
觀看數:0
回答數:2
收藏數:0
cvdl-1
cvdl-1-d09

我在今年2月裝的Anaconda可能因為Windows update壞了, 所以我把所有的python, Anaconda拆了. 重裝python3.7和最新的Anaconda 4.7.12. 但發現裏面不會有opencv 3.4.2 版, 只有opencv 4.1.2版. 

但是, 不但4.1.2裝不起來 ( UnsatisfiableError,  package conflict ), 連手動安裝指定版本都有package conflict.

 conda install -c conda-forge opencv=3.4.2

 conda install -c conda-forge libopencv=3.4.2

 conda install -c conda-forge py-opencv=3.4.2


我又用了Anaconda3-2019.07-Windows-x86_64.exe再去裝裝看, 還發現因為Windows update, 這7月的版本是有問題的.

惡搞許久, 感覺Anaconda還蠻落漆的.

請問可以去用最新版Anaconda  ( Anaconda3-2019.10-Windows-x86_64.exe ) 安裝看看, 並把openCV的安裝步驟寫給學員嗎?


這一版的DDL少了一些ssl 模組, 要加一點步驟才能下conda指令: ( 我的Anaconda 裝在D:\Anaconda3 )

   dos> cd /d D:\Anaconda3\Library\bin

   dos> copy libcrypto-1_1-x64.* D:\Anaconda3\DLLs\

   dos> copy libssl-1_1-x64.* D:\Anaconda3\DLLs\