logo
Loading...

關於 NLP 中的 使用 torch 問題, 執行 model 時產生的 error, 版本該如何解決 - Cupoy

各位專家好, 目前正在著手使用 torch 執行 BERT 程式參考的程式碼如該網址: https:...

torch,bert,dl

關於 NLP 中的 使用 torch 問題, 執行 model 時產生的 error, 版本該如何解決

2020/10/16 下午 00:29
機器學習共學討論版
Yun-Jung Hsu
觀看數:9
回答數:1
收藏數:0
torch
bert
dl

各位專家好, 

目前正在著手使用 torch 執行 BERT 程式

參考的程式碼如該網址: https://www.kaggle.com/jaskaransingh/bert-fine-tuning-with-pytorch


然而在安裝於 windows 主機遇到以下問題

 File "C:\ProgramData\Anaconda3\lib\site-packages\transformers\modeling_bert.py", line 1193, in forward

   loss = loss_fct(logits.view(-1, self.num_labels), labels.view(-1))

AttributeError: 'builtin_function_or_method' object has no attribute 'view'


有人說可能是版本問題, 但將此問題丟入 google 查詢, 無法知道我該使用哪個版本

請問該如何解決, 


如要提供相關其他套件版本會再一併提供


謝謝

回答列表

  • 2020/10/18 上午 01:09
    張維元 (WeiYuan)
    贊同數:1
    不贊同數:0
    留言數:2

    嗨,kaggle 上的例子有指定要用 2.8.0 的 「transformers」,請問你本機上是哪個安裝版本?


    很高興可以在這次問答進行討論,如果還有不懂或是模糊的部分也歡迎持續追問。期待你的互動與鼓勵創造出不同更深度的討論。歡迎加入我自己經營的Line 群組社群,會有不定時舉辦的分享活動,一起來玩玩吧!